mirror of
https://github.com/huggingface/text-generation-inference.git
synced 2025-04-19 22:02:06 +00:00
This is less incremental than crate2nix, but does build all dependencies separately, so avoids full rebuilds.
18 lines
240 B
Nix
18 lines
240 B
Nix
{
|
|
mkPoetryApplication,
|
|
pkg-config,
|
|
protobuf,
|
|
openssl,
|
|
}:
|
|
|
|
mkPoetryApplication {
|
|
# name = "text-generation-server";
|
|
|
|
projectDir = ./server;
|
|
|
|
# nativeBuildInputs = [ pkg-config ];
|
|
|
|
# buildInputs = [ openssl.dev protobuf ];
|
|
|
|
}
|