mirror of
https://github.com/huggingface/text-generation-inference.git
synced 2025-04-19 22:02:06 +00:00
* Stream options. * Fetch stuff from nix integration test for easier testing. * Adding the assert. * Only send the usage when asked for. * Update the docs. * Impure test because we need network. * develop. * Optional usage. * Fixes. * Workflow
22 lines
267 B
Nix
22 lines
267 B
Nix
{
|
|
buildPythonPackage,
|
|
poetry-core,
|
|
huggingface-hub,
|
|
pydantic,
|
|
}:
|
|
|
|
buildPythonPackage {
|
|
name = "text-generation";
|
|
|
|
src = ../clients/python;
|
|
|
|
pyproject = true;
|
|
|
|
build-system = [ poetry-core ];
|
|
|
|
dependencies = [
|
|
huggingface-hub
|
|
pydantic
|
|
];
|
|
}
|