mirror of
https://github.com/huggingface/text-generation-inference.git
synced 2025-04-19 22:02:06 +00:00
19 lines
303 B
Nix
19 lines
303 B
Nix
{ buildRustPackage, importCargoLock, pkg-config, protobuf, openssl }:
|
|
|
|
buildRustPackage {
|
|
name = "text-generation-lancher";
|
|
|
|
src = ./.;
|
|
|
|
sourceDir = ./launcher;
|
|
|
|
cargoLock = {
|
|
lockFile = ./Cargo.lock;
|
|
};
|
|
|
|
nativeBuildInputs = [ pkg-config ];
|
|
|
|
buildInputs = [ openssl.dev protobuf ];
|
|
|
|
}
|